Can't test on mobile "Version Mismatch"

Have any questions or problems in making your game, subscribing and/or using our software? Post here.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Use a very good subject. "Problem" or "Help" are unacceptable titles.

Use the search feature before posting a question, as the answer is probably already here.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
User avatar
tridecagon
Member
 
Joined: Sat Apr 04, 2015 1:19 am
Location: London, KY

Can't test on mobile "Version Mismatch"

Postby tridecagon » Wed Jun 15, 2016 1:45 pm

I decided to test a game on an Android. I followed the steps on the wiki but when I try to test the game, GG Maker tells me "192.168.0.2 - version mismatch (100835,100000,1.11.3)"

As far as I can tell, GG Maker is up to date. I'm going to build the game for Android to see if I can get it to run like that. I just gotta install Java SE Dev Kit 7 first.

*EDIT*
It failed to run.
I'm not the sharpest fork in the toaster.

User avatar
Mike
001 Co-Founder
 
Joined: Sun May 08, 2005 1:29 pm
Location: Ontario, Canada

Re: Can't test on mobile "Version Mismatch"

Postby Mike » Wed Jun 15, 2016 2:05 pm

Is there a specific error that comes up when you're testing a built Android game?

Is anyone else using the latest subscription version and experiencing this issue as well?

User avatar
tridecagon
Member
 
Joined: Sat Apr 04, 2015 1:19 am
Location: London, KY

Re: Can't test on mobile "Version Mismatch"

Postby tridecagon » Wed Jun 15, 2016 2:17 pm

What I put in quotes is the closest thing I get to an error. When I tried to run the built version on my phone, it just crashed instantly.
I'm not the sharpest fork in the toaster.

User avatar
Lee
001 Support
 
Joined: Thu Sep 21, 2006 1:59 pm
Location: United Kingdom

Re: Can't test on mobile "Version Mismatch"

Postby Lee » Fri Jun 17, 2016 5:34 am

The error occurs when using the "Test on Handheld Devices" feature. The game will be optimised and as it attempts to send it over to the device the version mismatch error will occur:

mismatch.png
mismatch.png (11.47 KiB) Viewed 949 times

This is my bad as I forgot to test this component before the subscription went live. You can blame me for this :P
Lee - 001 Community Manager

User avatar
Mike
001 Co-Founder
 
Joined: Sun May 08, 2005 1:29 pm
Location: Ontario, Canada

Re: Can't test on mobile "Version Mismatch"

Postby Mike » Fri Jun 17, 2016 1:06 pm

Fixed for next version.


Return to Technical Support Questions

Who is online

Users browsing this forum: No registered users

cron