Multiple controler support not working properly

Have any questions or problems in making your game, subscribing and/or using our software? Post here.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Use a very good subject. "Problem" or "Help" are unacceptable titles.

Use the search feature before posting a question, as the answer is probably already here.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
User avatar
JimmySterylian
001 Fanatic
 
Joined: Tue Jul 29, 2014 2:28 pm
Location:  ­ 

Multiple controler support not working properly

Postby JimmySterylian » Sat Jun 25, 2016 4:25 am

Today I went ahead to finally implement full controler support for all 4 players. I have set up everything correctly but other than Player 1, the other controlers don't seem to respond to their corresponding player(they all apply for player 1, not the options on the GamePad scroll downs but the buttons I input on the text field). I have used Pad[Number for respective player] and pressed the buttons on the text input box with the respective controler as well. All my controlers are Xbox 360 wireless ones by the way.
Image

User avatar
Lee
001 Support
 
Joined: Thu Sep 21, 2006 1:59 pm
Location: United Kingdom

Re: Multiple controler support not working properly

Postby Lee » Sat Jun 25, 2016 7:11 am

Unfortunately, this is something I cannot personally test as I only have 1 controller. Can someone else (who has access to multiple controllers) test this issue and confirm it's not working properly?
Lee - 001 Community Manager

User avatar
JimmySterylian
001 Fanatic
 
Joined: Tue Jul 29, 2014 2:28 pm
Location:  ­ 

Re: Multiple controler support not working properly

Postby JimmySterylian » Sat Jun 25, 2016 7:14 am

Did Mike have 4 controlers while implementing this feature or did he simply code it thinking in theory it would work?
Image

User avatar
Mike
001 Co-Founder
 
Joined: Sun May 08, 2005 1:29 pm
Location: Ontario, Canada

Re: Multiple controler support not working properly

Postby Mike » Sat Jun 25, 2016 8:25 am

I wasn't able to test, no.

I wouldn't mind getting a bug report from you with this issue. I could maybe borrow something in the meantime.

I still would like to get feedback from any other users experiencing this issue as well.

User avatar
JimmySterylian
001 Fanatic
 
Joined: Tue Jul 29, 2014 2:28 pm
Location:  ­ 

Re: Multiple controler support not working properly

Postby JimmySterylian » Sat Jun 25, 2016 3:07 pm

I have sent a bug report.
Image


Return to Technical Support Questions

Who is online

Users browsing this forum: No registered users

cron