Multiplayer Lag/Frame Rate Issue?

Have any questions or problems in making your game, subscribing and/or using our software? Post here.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Use a very good subject. "Problem" or "Help" are unacceptable titles.

Use the search feature before posting a question, as the answer is probably already here.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Multiplayer Lag/Frame Rate Issue?

Postby Danny » Fri Jul 22, 2016 9:21 pm

So am testing my game (2 instances) and for some reason it seems a little laggy, am testing on both instances in the editor (Not yet tried from another computer) but i checked the "Show Framerate" option and it seems one instant of the game as a totally different frame to the other instance and not just a slight framerate difference either, quite a gap.

How do i fix the frame rate so the game doesn't appear laggy?
Attachments
untitled.PNG

User avatar
JimmySterylian
001 Fanatic
 
Joined: Tue Jul 29, 2014 2:28 pm
Location:  ­ 

Re: Multiplayer Lag/Frame Rate Issue?

Postby JimmySterylian » Sat Jul 23, 2016 3:00 am

First of all, launching two game instances is technically running the game twice on your computer, that's one reason for some of the lag. Secondly, it appears that the active window game instance tends to have better framerate than the one that's lost focus. On two separate computers, it'll work fine without any issues.
Image

User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Re: Multiplayer Lag/Frame Rate Issue?

Postby Danny » Sat Jul 23, 2016 11:40 am

I made sure i unchecked the Freeze game option if it lost focus. I can't confirm the framerate yet cause i can't test via two computers due to issues but i hope it does fix itself then. Thank you. :)


Return to Technical Support Questions

Who is online

Users browsing this forum: No registered users

cron