Strange Behaviour with interface

Have any questions or problems in making your game, subscribing and/or using our software? Post here.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Use a very good subject. "Problem" or "Help" are unacceptable titles.

Use the search feature before posting a question, as the answer is probably already here.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Strange Behaviour with interface

Postby Danny » Sun Dec 06, 2015 12:56 pm

I have a actor template thats setup to open the Inn interface, this system as been design in a way where i only need one actor template called "Tavern Keeper" and when you activate/talk to this npc the Inn interface is suppose to open. Now for some reason when i place this actor template on the map called "Rattling Woods" the system i made bugs out, it brings up random interfaces related to my inventory, one minute it will bring up my weapons next the map, crafting system etc, its always a inventory related interface it brings up.

Sounds to me like something it clashing but odd thing is i can't figure out what it is, if i place this actor template onto any other map it works perfect but it seems to be specific to this map "Rattling Woods" my script appears to be setup correctly from what i can tell.

Below is the script that runs when you talk to the Inn keeper.



The script below is the script that runs once the above script as entered the data.



Now when the interface pops up its random like i mentioned, sometimes you can get the inn to pop up first but 95% chance a inventory interface opens first.

User avatar
RamchuK_Ntertainment
Ultimate 001 Member
 
Joined: Tue Sep 29, 2009 10:50 pm
Location: Seattle, Washington

Re: Strange Behaviour with interface

Postby RamchuK_Ntertainment » Sun Dec 06, 2015 2:01 pm

What are you running inside 'Enable Menus'? If you are turning on interfaces in there, it could be a problem, since the Inn interface is set to be turned on last and also run as "Parallel".
Travesty: 3D Survival - WIP >>> Forum Topic
University of Washington (BABA)
-REGT- Ramchuk Entertainment Games Team
Strategy/Action/Adventure
Copyrighted©2008-2017

User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Re: Strange Behaviour with interface

Postby Danny » Sun Dec 06, 2015 2:04 pm

RamchuK_Ntertainment wrote:What are you running inside 'Enable Menus'? If you are turning on interfaces in there, it could be a problem, since the Inn interface is set to be turned on last and also run as "Parallel".


Inside that Enable Menu is a HUD event set to "Turn Off" and a input trigger set to "Turn Off" the regular controls and "Turn On" the menu controls. Changing parallel to overlay does nothing.


Return to Technical Support Questions

Who is online

Users browsing this forum: No registered users

cron