Actor 1-2 Pixels off the ground platformer

Have any questions or problems in making your game, subscribing and/or using our software? Post here.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Use a very good subject. "Problem" or "Help" are unacceptable titles.

Use the search feature before posting a question, as the answer is probably already here.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Actor 1-2 Pixels off the ground platformer

Postby Danny » Sat Sep 03, 2016 5:11 pm

I've noticed some rather odd visual? behaviour in my game. When i "Jump" while walking left of right my actor doesn't completely set back on the floor, it hovers 1-2 pixels above the ground and then after around 0.1-1 second it will drop back to the floor. When i jump up and down on the spot without moving this issue doesn't occur.

I've checked my collison on my sprite and all seems to be in order. I've also noticed this issue actually occurs in the 001 Platformer template as well with the default 001 platformer actors. Is there any way to fix this? It make my game look rather glitchy all the time while performing jumps as you walk.

Below is a screenshot. Thanks.

Edit: Anyone?

Edit 2: Still need help with this.

Edit 3: Had to copy/paste, no more bump option. Been over 7 days. Anyone??
Attachments
untitled.PNG

User avatar
AnvilHouse
001 Support
 
Joined: Mon Mar 04, 2013 1:19 am
Location: Wisconsin, USA

Re: Actor 1-2 Pixels off the ground platformer

Postby AnvilHouse » Sat Sep 03, 2016 9:04 pm

Really i have no answer here...I dont experience this at all. Wish I had a better answer for you, no matter matter how much I try I cant get it like that XD

My suggestion is maybe delete the sprite then re-add it, usually fixes the problems i encounter in this area
Image Image Image

https://www.patreon.com/Anvilhouse ...yes...I am on Patreon!


-The store is under construction-
All items are guaranteed to work with 001 ;)

User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Re: Actor 1-2 Pixels off the ground platformer

Postby Danny » Sat Sep 03, 2016 9:21 pm

Tried it but still same issue, default 001 platformer does the same. :/

User avatar
epsilon017
001 Subscriber
 
Joined: Sun Jul 06, 2008 9:14 pm
Location: USA

Re: Actor 1-2 Pixels off the ground platformer

Postby epsilon017 » Tue Sep 06, 2016 10:03 pm

Does your game display any signs of lag or an otherwise choppy frame rate? I'm only going by a hypothesis right now, but I've had characters glitch through walls for that reason, and I've also experienced this same problem with some of my platformers.
Defenders of Sol (Demo): http://engine001.com/games/Defenders%20of%20Sol_3083.htm

I really have no idea what I'm doing.

User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Re: Actor 1-2 Pixels off the ground platformer

Postby Danny » Thu Sep 29, 2016 4:14 pm

I always get lag in my games. Yes.


Edit: This is still happening in my game, also the 001 demos and recently Ramchuk sent me a demo of a random world generator and it also does the same in his demo which is also 2D platformer. Surely this is no longer a issue with my collision? My game, another members games and 001 demos... also may i point out this only happens after jumping when the main actor falls back to the floor, he simply doesn't "Reconnect" correctly to the floor.
Last edited by Danny on Thu Sep 29, 2016 4:16 pm, edited 1 time in total.
Reason: Automatically merged double post.

User avatar
Mike
001 Co-Founder
 
Joined: Sun May 08, 2005 1:29 pm
Location: Ontario, Canada

Re: Actor 1-2 Pixels off the ground platformer

Postby Mike » Thu Sep 29, 2016 4:33 pm

If you slow down the fall rate (for example, gravity) and/or set a minimum framerate in settings, it'll alleviate this problem.

User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Re: Actor 1-2 Pixels off the ground platformer

Postby Danny » Thu Sep 29, 2016 4:42 pm

Mike wrote:If you slow down the fall rate (for example, gravity) and/or set a minimum framerate in settings, it'll alleviate this problem.


How would i slow the fall rate? The "Fall" section is greyed out in the player properties window, i know i can enable the fall window by selecting my player to "Fly" but am not using flying in-game. My frame rate is set to 30 (Minimum) i can go lower back to default 10 and see what the games like.

User avatar
JimmySterylian
001 Fanatic
 
Joined: Tue Jul 29, 2014 2:28 pm
Location:  ­ 

Re: Actor 1-2 Pixels off the ground platformer

Postby JimmySterylian » Fri Sep 30, 2016 1:05 am

Like Mike said, try tinkering with the Change Map Gravity event and see what happens.
Image

User avatar
Danny
001 Forum Master
 
Joined: Tue Jul 12, 2011 7:14 am

Re: Actor 1-2 Pixels off the ground platformer

Postby Danny » Fri Sep 30, 2016 1:20 am

JimmySterylian wrote:Like Mike said, try tinkering with the Change Map Gravity event and see what happens.


Yeah. I read what Mike said... No difference...

Edit: I adjusted the velocity of the jump from 36 to 40 and seems to have fixed the issue for now as far as am aware. The gravity didn't help unless i used it wrong, i adjusted on the Z using a negative value.

If i run into more issues closer to release i will come back to this topic. Thank you everyone.


Return to Technical Support Questions

Who is online

Users browsing this forum: No registered users

cron