Making a platformer. Something I'm missing? *Help*

Have any questions or problems in making your game, subscribing and/or using our software? Post here.
Forum rules
Make sure you are using the newest version. This can be downloaded at the top of the site via the "downloads" link.

Use a very good subject. "Problem" or "Help" are unacceptable titles.

Use the search feature before posting a question, as the answer is probably already here.

Subscript out of range error 9: This is a generic error, and we'll need way more information than that to figure out the problem. If you get this, strongly consider following the instructions of submitting your project through the Submit Bug feature within the editor.
Finnthewildcoon
Junior Member
 
Joined: Mon Oct 12, 2015 4:36 pm

Making a platformer. Something I'm missing? *Help*

Postby Finnthewildcoon » Mon Oct 12, 2015 4:40 pm

So to begin with and to simply put it in the most simple way possible. I've been trying to figure out why this has been happening and I'm not sure if it's something I'm not seeing or reading over incorrectly.
Every time I make a platform there seems to be like a invisible block above it and below it so my character/sprite cannot jump onto it or even go under it. Is it something with collision? I've been researching and looking it over and I find no answer. Probably because its THAT basic for me to even realize what I am doing wrong. I even followed the tutorial and its still doing the same thing. Any ideas? or is it a bug? I got GG Maker off steam if that helps.

Thank you, Finn

User avatar
Red_
Junior Member
 
Joined: Sun Aug 02, 2015 12:59 pm

Re: Making a platformer. Something I'm missing? *Help*

Postby Red_ » Wed Oct 14, 2015 8:55 pm

Could be something with the terraformations (concave and convex parts) but it's kinda hard to tell without any reference pictures or anything. If you don't want or need the terraformations you can always just do the one texture for the block and use that, that should get rid of any problems concerning "hitbox" style problems.

User avatar
AnvilHouse
001 Support
 
Joined: Mon Mar 04, 2013 1:19 am
Location: Wisconsin, USA

Re: Making a platformer. Something I'm missing? *Help*

Postby AnvilHouse » Wed Oct 14, 2015 10:04 pm

Did you place an invisible tile by accident? Try using the eraser tool in the trouble spots it might fix it.

-or if that doesnt work-

Is your camera set to side view? You may have it set to 45* by accident.

Let me know if either of those worked, if not, it would help if you made a video of your issue.

Red_ wrote:Could be something with the terraformations (concave and convex parts) but it's kinda hard to tell without any reference pictures or anything. If you don't want or need the terraformations you can always just do the one texture for the block and use that, that should get rid of any problems concerning "hitbox" style problems.


Terraformation has no bearing on collision problems, only with the way the connected faces are rendered.
Image Image Image

https://www.patreon.com/Anvilhouse ...yes...I am on Patreon!


-The store is under construction-
All items are guaranteed to work with 001 ;)


Return to Technical Support Questions

Who is online

Users browsing this forum: No registered users

cron